<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.pedestrian.tv/wp/xmlrpc.php">
<style>.async-hide { opacity: 0 !important} </style>
<script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;
    h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};
    (a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;
    })(window,document.documentElement,'async-hide','dataLayer',4000,
    {'GTM-M2XZSKP':true});</script>
<script type="text/javascript">
		var ajaxurl = 'https://www.pedestrian.tv/wp/wp-admin/admin-ajax.php';
		</script>
<script>
			var siteads = siteads || {},
				googletag = googletag || {};
			siteads.queue = siteads.queue || [];
			siteads.isLocal = 0;
			siteads.skipRequirements = 0;
			googletag.cmd = googletag.cmd || [];
			window._taboola = window._taboola || [];
		</script>
<script async src="https://z.moatads.com/pedestriangamheader824391166078/moatheader.js"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
			window.site = {};
			window.site.environment = 'production'
			window.scrollInViewport = {
				direction: 'down',
				sections: {
					loaded: 1,
					current: 1,
					sectionsInViewport: [ 1 ],
					count() {
						return window.scrollInViewport.sections.sectionsInViewport.length;
					},
				},
				setup() {
					var scrollPos = 0;
					window.addEventListener( 'scroll', function() {
						var top = ( document.body.getBoundingClientRect() ).top;
						window.scrollInViewport.direction = ( top > scrollPos ) ? 'up' : 'down';
						scrollPos = top;
					} );
				},
			};
			window.scrollInViewport.setup();
			window.getLoadTargeting = function() {
				return window.scrollInViewport.sections.loaded <= 10 ? window.scrollInViewport.sections.loaded.toString() : 'any';
			};
		</script>
<script type="text/javascript">var post_counter_api_details = {"ajax_url_v2":"https:\/\/www.pedestrian.tv\/post-counter\/v2\/","app_id":1,"post_id":1699774};</script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script>
	var digitalData = {"page":{"pageInfo":{"pageID":1699774,"pageName":"Snoop Dogg Just Announced His First Aussie Tour Since 2014 & The Grass Really Do Be Greener","brand":"pedestrian","generator":"WP","author":"Courtney Fry","effectiveDate":"2021-09-07 10:34:51","issueDate":"2021-09-07 10:34:51","issueDay":"2021-09-07","sysEnv":"desktop","inf":false},"category":{"pageType":"single","primaryCategory":"music","subCategory1":""},"ctype":"article","tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"tagsString":"Rap,Snoop Dogg,Australian Tour,2022,Arena Tour,Tour Announcement,I Wanna Thank Me,Doggfather"},"user":{"profile":[{"profileInfo":{"profileID":""},"membershipType":"visitor"}]},"load":1,"version":"1.0","events":[],"nielsen":{"apid":"PD7D1469C-BEAA-401F-B4D0-EE69706613C5","sitename":"pedestrian","section":"Pedestrian.TV Sites - other","sfcode":"dcr","nol_sdkDebug":""}};
</script>

<title>Snoop Dogg Just Announced His First Australian Tour Since 2014</title>
<meta name="description" content="The doggfather himself Snoop Dogg has just announced a run of Australian shows for late 2022, his first Aussie tour since 2014&#039;s Big Day Out." />
<link rel="canonical" href="https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Snoop Dogg Just Announced His First Aussie Tour Since 2014 &amp; The Grass Really Do Be Greener" />
<meta property="og:description" content="He&#039;ll be kicking off his big jaunt down under in October next year." />
<meta property="og:url" content="https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/" />
<meta property="og:site_name" content="Pedestrian TV" />
<meta property="article:publisher" content="https://www.facebook.com/pedestriandottv/" />
<meta property="article:published_time" content="2021-09-07T00:34:51+00:00" />
<meta property="og:image" content="https://imgix.pedestrian.tv/content/uploads/2021/09/07/snoop-dogg-tour-site.jpg?ar=16%3A9&auto=format&crop=focal&fit=crop&q=65&w=1200" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="675" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Snoop Dogg Just Announced His First Aussie Tour Since 2014" />
<meta name="twitter:description" content="The grass do be greener." />
<meta name="twitter:image" content="https://imgix.pedestrian.tv/content/uploads/2021/09/07/snoop-dogg-tour-site.jpg?ar=16%3A9&auto=format&crop=focal&fit=crop&q=65&w=1200" />
<meta name="twitter:creator" content="@courtwhip" />
<meta name="twitter:site" content="@pedestriandaily" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Courtney Fry">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="2 minutes">
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link href="https://fonts.googleapis.com" rel="preconnect" crossorigin><link href="https://securepubads.g.doubleclick.net" rel="preconnect"><link href="https://z.moatads.com" rel="preconnect"><link href="https://cdnjs.cloudflare.com" rel="preconnect"><link href="https://www.youtube.com" rel="preconnect"><link href="https://connect.facebook.net" rel="preconnect"><link href="https://code.jquery.com" rel="preconnect"><link href="https://adc-js.nine.com.au" rel="preconnect"><link href="https://js.gleam.io" rel="preconnect"><link href="https://clientcdn.pushengage.com" rel="preconnect"><link href="https://cdn.parsely.com" rel="preconnect"><link href="https://s.skimresources.com" rel="preconnect"><link href="https://share.9cdn.net" rel="preconnect"><link href="https://secure.adnxs.com" rel="preconnect"><link href="https://www.googletagmanager.com" rel="preconnect"><link href="https://static-au.plista.com" rel="preconnect"><link href="https://srv-2020-11-24-05.pixel.parsely.com" rel="preconnect"><link href="https://mb.moatads.com" rel="preconnect"><link href="https://px.moatads.com" rel="preconnect"><link href="https://gleam.io" rel="preconnect"><link href="https://static.plista.com" rel="preconnect"><link href="https://players.brightcove.net" rel="preconnect"><link href="https://r.skimresources.com" rel="preconnect"><link href="https://snap.licdn.com" rel="preconnect"><link href="https://static.hotjar.com" rel="preconnect"><link href="https://www.google-analytics.com" rel="preconnect"><link href="https://pedestrian-sydney.gscontxt.net" rel="preconnect"><link href="https://cdn-gl.imrworldwide.com" rel="preconnect"><link href="https://farm.plista.com" rel="preconnect"><link href="https://metrics.brightcove.com" rel="preconnect"><link href="https://script.hotjar.com" rel="preconnect"><link href="https://ampcid.google.com" rel="preconnect"><link rel="amphtml" href="https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/amp/" /><meta name="generator" content="AMP for WP 1.0.69.2" /><link rel="alternate" type="application/rss+xml" title="Pedestrian TV &raquo; Feed" href="https://www.pedestrian.tv/feed/" />
<link rel="alternate" type="application/rss+xml" title="Pedestrian TV &raquo; Comments Feed" href="https://www.pedestrian.tv/comments/feed/" />

<link rel="preload" href="https://imgix.pedestrian.tv/content/uploads/2021/09/07/snoop-dogg-tour-site.jpg?ar=16%3A9&auto=format&crop=focal&fit=crop&q=65&w=1200" as="image">
 <script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.pedestrian.tv\/wp\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='pedicons-css' href='https://www.pedestrian.tv/content/themes/pedestriantv/fonts/css/ped-icons.1566951714.css' type='text/css' media='all' />
<link rel='stylesheet' id='fonts-css' href='https://www.pedestrian.tv/content/themes/pedestriantv/fonts/css/fonts.1566951713.css' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css' href='https://www.pedestrian.tv/content/themes/pedestriantv/bootstrap/css/bootstrap.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='fields-css-css' href='https://www.pedestrian.tv/content/themes/pedestriantv/css/fields-form.1566951479.css' type='text/css' media='all' />
<link rel='stylesheet' id='ped-main-css-css' href='https://www.pedestrian.tv/content/themes/pedestriantv/css/main.1613694775.css' type='text/css' media='all' />
<link rel='stylesheet' id='ped-menu-css-css' href='https://www.pedestrian.tv/content/themes/pedestriantv/css/menu.1612906465.css' type='text/css' media='all' />
<link rel='stylesheet' id='pedestrian-style-css' href='https://www.pedestrian.tv/content/themes/pedestriantv/style.1615767256.css' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css-css' href='https://www.pedestrian.tv/content/themes/pedestriantv/css/slick.1566951480.css' type='text/css' media='all' />
<link rel='stylesheet' id='flickity-css' href='https://www.pedestrian.tv/content/themes/pedestriantv/css/lib/flickity.min.css?ver=2.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.pedestrian.tv/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.8' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='slick-slider-css' href='https://cdnjs.cloudflare.com/ajax/libs/slick-carousel/1.8.1/slick.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='pedestrian-quiz-css-css' href='https://www.pedestrian.tv/content/themes/pedestriantv/quiz/css/quiz.css?ver=1612744618' type='text/css' media='all' />
<link rel='stylesheet' id='wsl-widget-css' href='https://www.pedestrian.tv/content/plugins/wordpress-social-login-modified/assets/css/style.css?ver=5.8' type='text/css' media='all' />
<script type='text/javascript' src='https://www.pedestrian.tv/content/plugins/dot-embed/js/dot-embed-config.js?ver=5.8' id='dotembedconfig_js-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/plugins/dot-embed/js/dot-embed.min.js?ver=5.8' id='dotembed_js-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/wp/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/jQuery.dotdotdot/3.2.2/jquery.dotdotdot.js?ver=5.8' id='dotdotdot-js-js'></script>
<script type='text/javascript' id='pedestrian-video-player-js-extra'>
/* <![CDATA[ */
var video_view_qualifier = "3000";
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/pedestrian-video-player.1566951745.js' id='pedestrian-video-player-js'></script>
<script type='text/javascript' src='https://www.youtube.com/player_api?ver=5.8' id='youtube-video-api-js'></script>
<script type='text/javascript' src='https://connect.facebook.net/en_US/sdk.js?ver=5.8' id='facebook-video-api-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/lib/flickity.pkgd.min.js?ver=2.1.2' id='flickity-js'></script>
<script type='text/javascript' src='https://www.youtube.com/iframe_api?ver=5.8' id='youtube-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/jquery.waypoints.min.1566951738.js' id='waypoints-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/inview.min.1566951743.js' id='inview-js'></script>
<script type='text/javascript' id='ads-ad-tech-js-js-extra'>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</script>
<script type='text/javascript' async src='https://www.pedestrian.tv/content/mu-plugins/ads/view/dist/js/ad-tech.min.js?ver=1623213531' id='ads-ad-tech-js-js'></script>
<script type='text/javascript' id='trending_article_section_settings-js-extra'>
/* <![CDATA[ */
var trending_impression_counter_api = {"ajax_url":"https:\/\/www.pedestrian.tv\/trending-impression-counter\/","app_id":"trending_impressions","rest_base_url":"https:\/\/www.pedestrian.tv\/wp-json\/pedestrian\/v1\/","is_single":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/trending-article-section-impressions.js?ver=1606346373' id='trending_article_section_settings-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/slick-carousel/1.8.1/slick.min.js?ver=5.8' id='slick-slider-js'></script>
<script type='text/javascript' src='https://code.jquery.com/ui/1.11.4/jquery-ui.js?ver=5.8' id='jquery-ui-js'></script>
<script type='text/javascript' async="async" src='https://js.gleam.io/oi-0mb1aae.js?ver=5.8' id='gleam-services-js'></script>
<script type='text/javascript' src='https://adc-js.nine.com.au/adc.js?ver=5.8' id='nine/adc-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/mu-plugins/pedestrian/libraries/post-counter/js/post-counter.js?ver=1566953647' id='post-counter-js'></script>
<link rel="https://api.w.org/" href="https://www.pedestrian.tv/wp-json/" /><link rel="alternate" type="application/json" href="https://www.pedestrian.tv/wp-json/wp/v2/posts/1699774" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.pedestrian.tv/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.pedestrian.tv/wp/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8" />
<link rel='shortlink' href='https://www.pedestrian.tv/?p=1699774' />
<link rel="alternate" type="application/json+oembed" href="https://www.pedestrian.tv/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.pedestrian.tv%2Fmusic%2Fsnoop-dogg-australian-tour-2022%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.pedestrian.tv/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.pedestrian.tv%2Fmusic%2Fsnoop-dogg-australian-tour-2022%2F&#038;format=xml" />

<script type="text/javascript">
            // Nine Third Party Kit - Loader
            var NINEAU_SiteName = 'PTV news';

            (function () {
                var LOADER_SCRIPT_URL = 'http://share.9cdn.net/share/short_cache/js/third_party/loaders/au.loader-latest.min.js';
                var LOADER_SCRIPT_URL_SECURE = 'https://share.9cdn.net/share/short_cache/js/third_party/loaders/au.loader-latest.min.js';
                var loaderScriptUrl = (window.location.protocol == 'https:') ? LOADER_SCRIPT_URL_SECURE : LOADER_SCRIPT_URL;
                document.write('<scr' + 'ipt type="text/javascript" src="' + loaderScriptUrl + '"></scr' + 'ipt>');
            }());
        </script>


<script type="text/javascript">
            //Nine Third Party Kit - Configuration
            NINEAU_Loader.setup();

            //Third Party Kit - Partner Configuration Block Start
            NINEAU_Config.setCategory('PedestrianTV');
            NINEAU_Config.setSiteName(NINEAU_SiteName);
            NINEAU_Config.setSectionName('music');
            NINEAU_Config.setSubsectionName( "Snoop Dogg Just Announced His First Aussie Tour Since 2014 & The Grass Really Do Be Greener" );
            NINEAU_Config.setNielsenEnabled(false);
			NINEAU_Config.setAdsEnabled(false);

            NINEAU_Config.setDmpEnabled(true);
            NINEAU_Config.setDmpValue('AU Pedestrian Tv - music');

            //Third Party Kit - Partner Configuration Block End
            NINEAU_ThirdParty.initialize();
        </script>

<script type="text/javascript">window.loggedOnDOMLoaded=!1,window.loggedOnDOMComplete=!1,window.onDOMLoad=function(o,e){const n=function(){"function"==typeof o&&(void 0===e?o():o(e))};"loading"!==document.readyState?(window.loggedOnDOMLoaded||(window.loggedOnDOMLoaded=!0,console.log("%conDOMLoad: document readyState !== 'loading'","background: #242424; color: yellow;")),n()):document.addEventListener?document.addEventListener("DOMContentLoaded",function(){window.loggedOnDOMLoaded||(window.loggedOnDOMLoaded=!0,console.log("%conDOMLoad: document 'DOMContentLoaded' event triggered","background: #242424; color: yellow;")),n()}):document.attachEvent("onreadystatechange",function(){"loading"!==document.readyState&&(window.loggedOnDOMLoaded||(window.loggedOnDOMLoaded=!0,console.log("%conDOMLoad: event onreadystatechange, document.readyState !== 'loading'","background: #242424; color: yellow;")),n())})},window.onDOMComplete=function(o,e){const n=function(){"function"==typeof o&&(void 0===e?o():o(e))};"complete"===document.readyState?(window.loggedOnDOMComplete||(window.loggedOnDOMComplete=!0,console.log("%conDOMLoad: document readyState === 'complete'","background: #242424; color: yellow;")),n()):window.addEventListener?window.addEventListener("load",function(){window.loggedOnDOMComplete||(window.loggedOnDOMComplete=!0,console.log("%conDOMLoad: window 'load' event triggered","background: #242424; color: yellow;")),n()}):document.attachEvent("onreadystatechange",function(){"complete"===document.readyState&&(window.loggedOnDOMComplete||(window.loggedOnDOMComplete=!0,console.log("%conDOMLoad: event onreadystatechange, document.readyState === 'complete'","background: #242424; color: yellow;")),n())})};</script>

<script>( function( w, d, s, l, i ) {
		w[ l ] = w[ l ] || [];
		w[ l ].push( {
			'gtm.start':
				new Date().getTime(), event: 'gtm.js'
		} );
		var f = d.getElementsByTagName( s )[ 0 ],
			j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
		j.async = true;
		j.src =
			'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
		f.parentNode.insertBefore( j, f );
	} )( window, document, 'script', 'dataLayer', 'GTM-W5PMGDG' );</script>


<script type="text/javascript">//<![CDATA[
  function external_links_in_new_windows_loop() {
    if (!document.links) {
      document.links = document.getElementsByTagName('a');
    }
    var change_link = false;
    var force = '';
    var ignore = 'https://imgix.pedestrian.tv';

    for (var t=0; t<document.links.length; t++) {
      var all_links = document.links[t];
      change_link = false;
      
      if(document.links[t].hasAttribute('onClick') == false) {
        // forced if the address starts with http (or also https), but does not link to the current domain
        if(all_links.href.search(/^http/) != -1 && all_links.href.search('www.pedestrian.tv') == -1 && all_links.href.search(/^#/) == -1) {
          // console.log('Changed ' + all_links.href);
          change_link = true;
        }
          
        if(force != '' && all_links.href.search(force) != -1) {
          // forced
          // console.log('force ' + all_links.href);
          change_link = true;
        }
        
        if(ignore != '' && all_links.href.search(ignore) != -1) {
          // console.log('ignore ' + all_links.href);
          // ignored
          change_link = false;
        }

        if(change_link == true) {
          // console.log('Changed ' + all_links.href);
          document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
          document.links[t].removeAttribute('target');
        }
      }
    }
  }
  
  // Load
  function external_links_in_new_windows_load(func)
  {  
    var oldonload = window.onload;
    if (typeof window.onload != 'function'){
      window.onload = func;
    } else {
      window.onload = function(){
        oldonload();
        func();
      }
    }
  }

  external_links_in_new_windows_load(external_links_in_new_windows_loop);
  //]]></script>

<meta name="parsely-title" content="Snoop Dogg Just Announced His First Aussie Tour Since 2014 &amp; The Grass Really Do Be Greener" />
<meta name="parsely-link" content="https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/" />
<meta name="parsely-type" content="post" />
<meta name="parsely-image-url" content="https://www.pedestrian.tv/content/uploads/2021/09/07/snoop-dogg-tour-site-150x150.jpg" />
<meta name="parsely-pub-date" content="2021-09-07T00:34:51Z" />
<meta name="parsely-section" content="Music" />
<meta name="parsely-tags" content="rap,snoop dogg,australian tour,2022,arena tour,tour announcement,i wanna thank me,doggfather" />
<meta name="parsely-author" content="Courtney Fry" />

<link rel="icon" href="https://www.pedestrian.tv/content/uploads/2017/07/cropped-Pez-Circle-Black-RGB-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.pedestrian.tv/content/uploads/2017/07/cropped-Pez-Circle-Black-RGB-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.pedestrian.tv/content/uploads/2017/07/cropped-Pez-Circle-Black-RGB-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.pedestrian.tv/content/uploads/2017/07/cropped-Pez-Circle-Black-RGB-270x270.png" />
<div class="audience-insider-pedtv">

<img src="https://secure.adnxs.com/px?id=995412&order_id=music&t=2" width="1" height="1" />

</div>
<script type="text/javascript">
        ( function( $ ) {

            var destroy_kargo_ads = function() {

              var register = (window.Kargo || {}).CreativeRegister;

              if (register) {
                var hovers = register.getCreativesOfType('Hover');

                if (hovers) {
                  hovers.forEach(function(hover) {
                    hover.destroy();
                  });
                }
              }

              $( window ).unbind( 'inf_content_added', destroy_kargo_ads );
              console.log( 'Kargo ads destroyed' );

            };

            $( window ).on( 'inf_content_added', destroy_kargo_ads );

        } )( jQuery );
    </script>
<script> window._peq = window._peq || []; window._peq.push(["init"]); </script>
<script src="https://clientcdn.pushengage.com/core/68da3e32fb8b1df000401b34e2d2d32c.js" async></script>

</head>
<body class="post-template-default single single-post postid-1699774 single-format-standard group-blog">

<noscript>
	<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W5PMGDG" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>

<div id="ad-slot_one-by-one_section-index-1_pos-1" class="ad-slot ad-slot-rendering ad-slot-one-by-one" data-section-index=1></div>
<script type="text/javascript">
		if (typeof siteads.queue !== 'undefined') {
			siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"one-by-one","targeting":{"ptv-pos":1},"provider":"google-dfp","element_id":"ad-slot_one-by-one_section-index-1_pos-1"} );
		}
	</script>
<nav class="navbar black navbar-default">
<div class="container">
<div class="navbar-header">
<a href="https://www.pedestrian.tv/jobs/" rel="home" data-element-tracking="jobs-logo" class="jobs-ptv-logo">
<img class="d-block-desktop" src="https://www.pedestrian.tv/content/themes/pedestriantv/images/jobs-new-logo.svg" alt="Jobs Logo" loading="lazy">
<img class="d-block-mobile" src="https://www.pedestrian.tv/content/themes/pedestriantv/images/jobs-logo-no-face.svg" alt="Jobs Logo" loading="lazy">
</a>
<div id="pedestrian-logo-ctn" class="pedestrian-logo-ctn">
<div id="pedestrian-logo-link-ctn" class="pedestrian-logo-link-ctn">
<a href="https://www.pedestrian.tv/" rel="home" class="pedestrian-logo-link"></a>
</div>
<div id="pedestrian-logo-std" class="pedestrian-logo">
<svg xmlns="http://www.w3.org/2000/svg" width="100%" viewBox="0 0 340 54.938">
<path id="pedestrian_logo" class="logo-1" d="M240.746,34.445h25.9V45.2H252.155v7.474h14.054V63.428H252.155v8.239H266.65V82.44h-25.9V34.445Zm68.49,0h25.926V45.2h-14.5v7.474h14.054V63.428H320.657v8.239h14.5V82.44H309.236V34.445Zm60.058,34.177c0,7-3.915,14.722-16.266,14.722-13.49,0-16.839-9.083-16.839-15.237V66.548h11.846c0,5.578,3.357,6.542,4.863,6.542a4.561,4.561,0,0,0,4.539-4.6c0-3.186-1.945-3.966-9.147-7.069-3.265-1.356-11.4-4.733-11.4-13.748s8.5-14.135,16.324-14.135c4.607,0,9.586,1.745,12.617,5.446,2.76,3.491,2.955,6.741,3.089,9.467h-11.8c-0.248-1.624-.635-4.668-4.285-4.668a3.929,3.929,0,0,0-4.1,3.759c0,2.85,1.25,3.43,9.643,7.327C367.094,58.892,369.294,63.043,369.294,68.622ZM234.62,37.947c-2.515-2.15-5.736-3.5-14.368-3.5H205v48h11.405V67.392h5.184c7.246,0,10.388-1.36,13.6-4.157,2.961-2.6,4.918-7.711,4.918-12.581A16.5,16.5,0,0,0,234.62,37.947Zm-13.36,18.68h-4.855V45.2h4.411c2.594,0,7.877,0,7.877,5.657C228.693,56.626,223.538,56.626,221.26,56.626Zm62.129-22.181H267.937v48h16.331c17.708,0,24.02-11.031,24.02-24.129,0-5.257-1.072-10.379-4.281-14.913C297.951,34.445,288.632,34.445,283.389,34.445Zm1.573,37.222h-5.1V45.2h5.16c5.3,0,7.693,2.29,9.081,4.421a17.328,17.328,0,0,1,2.265,8.88C296.369,65.308,293.85,71.667,284.962,71.667Zm137.857-5.574c8.817-1.488,11.59-9.6,11.59-15.118,0-4.932-1.878-9.984-5.724-13.1-3.032-2.391-6.187-3.428-14.375-3.428H369.294V45.2H378.5V82.44H390.42V45.2h9.134V82.44h11.415v-15.5H411.1l10.782,15.5H435.5Zm-7.636-7.526h-4.214V45.2h4.344c4.591,0,7.681,2.147,7.681,6.5C422.994,54.04,422.178,58.567,415.183,58.567Zm21.061-24.122h11.931v48H436.244V34.445Zm108.756,0v48H534.663L516.88,53.249l-0.124.065,0.327,29.126h-8.138c0.185-.117.4-0.242,0.591-0.367,3.751-2.4,3.412-4.61,3.3-5a2.916,2.916,0,0,0-1.547-2.048,4.023,4.023,0,0,0-1.91-.437,9.48,9.48,0,0,0-3.12.639c-0.2.039-.388,0.063-0.6,0.1V34.445h10.281l18.024,30.16,0.124-.136-0.5-30.024H545ZM500.786,72.921L482.62,34.336h2.169l17.917,37.717Zm-7.51,3.4L473.514,34.336h1.813l19.427,41.311Zm2.488-1.137-19.219-40.85h1.816L497.27,74.513Zm-5,2.273L470.469,34.336h1.807l19.993,42.448Zm7.522-3.389L479.567,34.336h1.827l18.381,39.051Zm-44.1-1.579,15.359-32.637,0.607,1.293-14.961,31.82,1.477,0.7,14.389-30.6,0.619,1.3L457.668,74.147l1.49,0.706,13.414-28.562,0.634,1.3L460.154,75.318l1.486,0.7,12.469-26.508,0.607,1.307L462.631,76.492l1.924,0.9,11.334-24.113,12.02,25.461,1.837-.834L469.252,34.336h-2.306L449.924,70.477l1.766,0.834,16.332-34.682,0.608,1.307L452.693,71.785l1.494,0.706m56.545,3.465a1.136,1.136,0,0,1,.373.265,2,2,0,0,1,.66,1.123c0.044,0.087.416,1.79-2.848,3.867a11.85,11.85,0,0,1-7.636,1.855c-0.627-.019-2.375.114-2.943,0.791a0.75,0.75,0,0,0-.179.6,0.2,0.2,0,0,1,.057.081,5.74,5.74,0,0,1,.475,1.259l-5.955,2.577-0.114-.036c-0.028-.014-0.97-2.176-0.97-2.176,0-.024-3.609-2.19-2.4-5.968a9.183,9.183,0,0,1,.335-0.9l0.091-.207,0.213,0.027a11.356,11.356,0,0,0,9.16-3.928l0.185-.21,0.219,0.138a9.7,9.7,0,0,0,7.056,1.108c0.112-.032,2.713-1.077,4.224-0.265M466.9,86.409a1.96,1.96,0,0,1-.406,1.234c-0.053.071-1.049,1.488-4.794,0.414a11.93,11.93,0,0,1-6.434-4.476c-0.414-.483-1.671-1.715-2.546-1.7a0.756,0.756,0,0,0-.552.278,0.129,0.129,0,0,0-.022.1,8.434,8.434,0,0,1-.644,1.194l-2.07-.983V72.657a0.046,0.046,0,0,0,.025-0.01,6.4,6.4,0,0,1,.895-0.333l0.209-.075,0.13,0.167a11.33,11.33,0,0,0,9,4.284l0.288-.014,0.04,0.264a9.876,9.876,0,0,0,3.828,6.022c0.1,0.049,2.594,1.314,3.006,2.984A2.952,2.952,0,0,1,466.9,86.409Z" transform="translate(-205 -33.531)" />
</svg>
</div>
</div>
<div class="sticky-page-title">
Snoop Dogg Just Announced His First Aussie Tour Since 2014 & The Grass Really Do Be Greener </div>
<a class="facebook-share" href="https://www.facebook.com/sharer/sharer.php?u=https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/" onclick="return !window.open(this.href, 'Facebook', 'width=640,height=580')" rel="noopener">
<img src="https://www.pedestrian.tv/content/themes/pedestriantv/images/facebook-w-1.png" width="90px" height="30px" alt="Share on Facebook" loading="lazy">
</a>
<button type="button" class="navbar-toggle navbar-right" data-toggle="collapse" data-target="#navbar-collapse-main">
<img src="https://www.pedestrian.tv/content/themes/pedestriantv/images/Menu-white.svg" width="32px" height="20px" loading="lazy">
</button>
</div>
</div>
</nav>
<div id="main-menu" class="ped-menu menu_collapse menu_bg_black">
<div class="bk_close_div black_bg">
<div class="container">
<div class="div_close white">
<button type="button" class="navbar-close navbar-right" data-toggle="collapse" data-target="#navbar-collapse-main">
<img src="https://www.pedestrian.tv/content/themes/pedestriantv/images/Close-white.svg" width="24px" height="24px" loading="lazy">
</button>
</div>
</div>
</div>
<div class="menu_nav_scroll">
<div class="menu_blk_black">
<div class="container">
<div class="container-fluid">
<div class="row">
<div class="col-md-12">
<div class="search-menu"><form role="search" method="get" action="https://www.pedestrian.tv" class="search-form">
<div class="form-group_search">
<div class="input-group input-group-xs">
<input type="search" class="form-control" placeholder="Search" value="" name="s" />
<span class="input-group-btn">
<button class="btn btn-primary" id="searchsubmit">
<i class="pd-icon pd-icon-search"></i>
</button>
</span>
</div>
</div>
</form>
</div>
</div>
</div>
<div class="row">
<div class="col-md-4 col-sm-4">
<div class="newsletter mobile_visible">
<div class="panel-heading"></div>
<div id="newsletter-signup-1502174059" class="panel-body">
<span class="success_message" style="display:none;"><div class="text-center">Thanks for signing up!</div></span>
<form data-id="embedded_signup:form" class="ctct-custom-form Form" name="embedded_signup" method="POST" action="https://visitor2.constantcontact.com/api/signup">

<input data-id="ca:input" type="hidden" name="ca" value="8e88cf51-7741-4bf5-9581-3cc0d157c7be">
<input data-id="list:input" type="hidden" name="list" value="2">
<input data-id="source:input" type="hidden" name="source" value="EFD">
<input data-id="required:input" type="hidden" name="required" value="list,email">
<input data-id="url:input" type="hidden" name="url" value="">
<input data-id="address_state:input" type="hidden" name="address_state" value="In menu">
<div class="form-group">
<div class="input-group input-group-sm">
<p data-id="Email Address:p"><input data-id="Email Address:input" type="email" name="email" value="" required="required" class="form-control" placeholder="Enter Your Email For Daily News"></p>
<span class="input-group-btn">
<button type="submit" class="Button ctct-button Button--block Button-secondary btn btn-primary" data-enabled="enabled">Submit</button>
</span>
</div>
</div>
</form>
</div>
<script type='text/javascript'>
  ( function($) {
      var $newsletter_form = $( '#newsletter-signup-1502174059' );
      if( typeof jQuery.fn.addNewsletter == 'function' ) {
          $newsletter_form.addNewsletter();
      } else {
          $( document ).on( 'add_newsletter_loaded', function() {
              $newsletter_form.addNewsletter();
          } );
      }
  } )(jQuery);
</script> </div>
<nav class="top_menu">
<ul id="menu-top-nav-left" class=""><li id="menu-item-1264690" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1264690"><a title="News" href="https://www.pedestrian.tv/news/">News</a></li>
<li id="menu-item-473086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-473086"><a title="Entertainment" href="https://www.pedestrian.tv/entertainment/">Entertainment</a></li>
<li id="menu-item-1308675" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1308675"><a title="Style" href="https://www.pedestrian.tv/style/">Style</a></li>
<li id="menu-item-1450198" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1450198"><a title="Online" href="https://www.pedestrian.tv/online/">Online</a></li>
<li id="menu-item-1308676" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1308676"><a title="Tech + Gaming" href="https://www.pedestrian.tv/tech-gaming/">Tech + Gaming</a></li>
<li id="menu-item-1217003" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1217003"><a title="Music" href="https://www.pedestrian.tv/music/">Music</a></li>
<li id="menu-item-1308677" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1308677"><a title="Sport" href="https://www.pedestrian.tv/sport/">Sport</a></li>
</ul> </nav>
</div>
<div class="col-md-4 col-sm-4">
<nav class="top_menu">
<ul id="menu-top-nav-central" class=""><li id="menu-item-1690591" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1690591"><a title="Travel" href="https://www.pedestrian.tv/travel/">Travel</a></li>
<li id="menu-item-1690592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1690592"><a title="Sex + Dating" href="https://www.pedestrian.tv/sex-dating/">Sex + Dating</a></li>
<li id="menu-item-1599366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1599366"><a title="Home" href="https://www.pedestrian.tv/life/home/">Home</a></li>
<li id="menu-item-1308680" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1308680"><a title="Health" href="https://www.pedestrian.tv/health/">Health</a></li>
<li id="menu-item-1308681" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1308681"><a title="Bites" href="https://www.pedestrian.tv/bites/">Bites</a></li>
<li id="menu-item-1690595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1690595"><a title="Skilling It" href="https://www.pedestrian.tv/careers/">Skilling It</a></li>
<li id="menu-item-1574455" class="menu-item-yellow menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1574455"><a title="Disney+" href="https://www.pedestrian.tv/disney/">Disney+</a></li>
</ul> </nav>
</div>
<div class="col-md-4 col-sm-4">
<div class="top_blk_right">
<div class="newsletter desktop_visible">
<div class="panel-heading"></div>
<div id="newsletter-signup-615684981" class="panel-body">
<span class="success_message" style="display:none;"><div class="text-center">Thanks for signing up!</div></span>
<form data-id="embedded_signup:form" class="ctct-custom-form Form" name="embedded_signup" method="POST" action="https://visitor2.constantcontact.com/api/signup">

<input data-id="ca:input" type="hidden" name="ca" value="8e88cf51-7741-4bf5-9581-3cc0d157c7be">
<input data-id="list:input" type="hidden" name="list" value="2">
<input data-id="source:input" type="hidden" name="source" value="EFD">
<input data-id="required:input" type="hidden" name="required" value="list,email">
<input data-id="url:input" type="hidden" name="url" value="">
<input data-id="address_state:input" type="hidden" name="address_state" value="In menu">
<div class="form-group">
<div class="input-group input-group-sm">
<p data-id="Email Address:p"><input data-id="Email Address:input" type="email" name="email" value="" required="required" class="form-control" placeholder="Enter Your Email For Daily News"></p>
<span class="input-group-btn">
<button type="submit" class="Button ctct-button Button--block Button-secondary btn btn-primary" data-enabled="enabled">Submit</button>
</span>
</div>
</div>
</form>
</div>
<script type='text/javascript'>
  ( function($) {
      var $newsletter_form = $( '#newsletter-signup-615684981' );
      if( typeof jQuery.fn.addNewsletter == 'function' ) {
          $newsletter_form.addNewsletter();
      } else {
          $( document ).on( 'add_newsletter_loaded', function() {
              $newsletter_form.addNewsletter();
          } );
      }
  } )(jQuery);
</script> </div>
<a href="https://www.pedestrian.tv/" rel="home" class="pedestrian-logo">
<svg xmlns="http://www.w3.org/2000/svg" width="100%" viewBox="0 0 340 54.938">
<path id="pedestrian_logo" class="logo-1" d="M240.746,34.445h25.9V45.2H252.155v7.474h14.054V63.428H252.155v8.239H266.65V82.44h-25.9V34.445Zm68.49,0h25.926V45.2h-14.5v7.474h14.054V63.428H320.657v8.239h14.5V82.44H309.236V34.445Zm60.058,34.177c0,7-3.915,14.722-16.266,14.722-13.49,0-16.839-9.083-16.839-15.237V66.548h11.846c0,5.578,3.357,6.542,4.863,6.542a4.561,4.561,0,0,0,4.539-4.6c0-3.186-1.945-3.966-9.147-7.069-3.265-1.356-11.4-4.733-11.4-13.748s8.5-14.135,16.324-14.135c4.607,0,9.586,1.745,12.617,5.446,2.76,3.491,2.955,6.741,3.089,9.467h-11.8c-0.248-1.624-.635-4.668-4.285-4.668a3.929,3.929,0,0,0-4.1,3.759c0,2.85,1.25,3.43,9.643,7.327C367.094,58.892,369.294,63.043,369.294,68.622ZM234.62,37.947c-2.515-2.15-5.736-3.5-14.368-3.5H205v48h11.405V67.392h5.184c7.246,0,10.388-1.36,13.6-4.157,2.961-2.6,4.918-7.711,4.918-12.581A16.5,16.5,0,0,0,234.62,37.947Zm-13.36,18.68h-4.855V45.2h4.411c2.594,0,7.877,0,7.877,5.657C228.693,56.626,223.538,56.626,221.26,56.626Zm62.129-22.181H267.937v48h16.331c17.708,0,24.02-11.031,24.02-24.129,0-5.257-1.072-10.379-4.281-14.913C297.951,34.445,288.632,34.445,283.389,34.445Zm1.573,37.222h-5.1V45.2h5.16c5.3,0,7.693,2.29,9.081,4.421a17.328,17.328,0,0,1,2.265,8.88C296.369,65.308,293.85,71.667,284.962,71.667Zm137.857-5.574c8.817-1.488,11.59-9.6,11.59-15.118,0-4.932-1.878-9.984-5.724-13.1-3.032-2.391-6.187-3.428-14.375-3.428H369.294V45.2H378.5V82.44H390.42V45.2h9.134V82.44h11.415v-15.5H411.1l10.782,15.5H435.5Zm-7.636-7.526h-4.214V45.2h4.344c4.591,0,7.681,2.147,7.681,6.5C422.994,54.04,422.178,58.567,415.183,58.567Zm21.061-24.122h11.931v48H436.244V34.445Zm108.756,0v48H534.663L516.88,53.249l-0.124.065,0.327,29.126h-8.138c0.185-.117.4-0.242,0.591-0.367,3.751-2.4,3.412-4.61,3.3-5a2.916,2.916,0,0,0-1.547-2.048,4.023,4.023,0,0,0-1.91-.437,9.48,9.48,0,0,0-3.12.639c-0.2.039-.388,0.063-0.6,0.1V34.445h10.281l18.024,30.16,0.124-.136-0.5-30.024H545ZM500.786,72.921L482.62,34.336h2.169l17.917,37.717Zm-7.51,3.4L473.514,34.336h1.813l19.427,41.311Zm2.488-1.137-19.219-40.85h1.816L497.27,74.513Zm-5,2.273L470.469,34.336h1.807l19.993,42.448Zm7.522-3.389L479.567,34.336h1.827l18.381,39.051Zm-44.1-1.579,15.359-32.637,0.607,1.293-14.961,31.82,1.477,0.7,14.389-30.6,0.619,1.3L457.668,74.147l1.49,0.706,13.414-28.562,0.634,1.3L460.154,75.318l1.486,0.7,12.469-26.508,0.607,1.307L462.631,76.492l1.924,0.9,11.334-24.113,12.02,25.461,1.837-.834L469.252,34.336h-2.306L449.924,70.477l1.766,0.834,16.332-34.682,0.608,1.307L452.693,71.785l1.494,0.706m56.545,3.465a1.136,1.136,0,0,1,.373.265,2,2,0,0,1,.66,1.123c0.044,0.087.416,1.79-2.848,3.867a11.85,11.85,0,0,1-7.636,1.855c-0.627-.019-2.375.114-2.943,0.791a0.75,0.75,0,0,0-.179.6,0.2,0.2,0,0,1,.057.081,5.74,5.74,0,0,1,.475,1.259l-5.955,2.577-0.114-.036c-0.028-.014-0.97-2.176-0.97-2.176,0-.024-3.609-2.19-2.4-5.968a9.183,9.183,0,0,1,.335-0.9l0.091-.207,0.213,0.027a11.356,11.356,0,0,0,9.16-3.928l0.185-.21,0.219,0.138a9.7,9.7,0,0,0,7.056,1.108c0.112-.032,2.713-1.077,4.224-0.265M466.9,86.409a1.96,1.96,0,0,1-.406,1.234c-0.053.071-1.049,1.488-4.794,0.414a11.93,11.93,0,0,1-6.434-4.476c-0.414-.483-1.671-1.715-2.546-1.7a0.756,0.756,0,0,0-.552.278,0.129,0.129,0,0,0-.022.1,8.434,8.434,0,0,1-.644,1.194l-2.07-.983V72.657a0.046,0.046,0,0,0,.025-0.01,6.4,6.4,0,0,1,.895-0.333l0.209-.075,0.13,0.167a11.33,11.33,0,0,0,9,4.284l0.288-.014,0.04,0.264a9.876,9.876,0,0,0,3.828,6.022c0.1,0.049,2.594,1.314,3.006,2.984A2.952,2.952,0,0,1,466.9,86.409Z" transform="translate(-205 -33.531)" />
</svg>
</a>
<ul class="social-icons">
<li>
<a href="https://www.facebook.com/pedestriandottv/" target="_blank">
<i class="pd-icon pd-icon-social-facebook"></i>
</a>
</li>
<li>
<a href="https://twitter.com/pedestriandaily" target="_blank">
<i class="pd-icon pd-icon-social-twitter"></i>
</a>
</li>
<li>
<a href="https://www.instagram.com/pedestriantv/" target="_blank">
<i class="pd-icon pd-icon-social-instagram"></i>
</a>
</li>
<li>
<a href="https://www.snapchat.com/add/pedestrian.tv" target="_blank">
<i class="pd-icon pd-icon-social-snapchat"></i>
</a>
</li>
<li>
<a href="https://www.youtube.com/user/pedestriantv" target="_blank">
<i class="pd-icon pd-icon-social-youtube"></i>
</a>
</li>
<li>
<a href="mailto:editor@pedestriangroup.com.au">
<i class="pd-icon pd-icon-social-email"></i>
</a>
</li>
</ul>
<div class="new-titles">
<a href="https://www.businessinsider.com.au/" target="_blank">
<img src="https://www.pedestrian.tv/content/themes/pedestriantv/images/business-insider.svg" alt="Businessinsider" loading="lazy">
</a>
<a href="https://www.lifehacker.com.au/" target="_blank">
<img src="https://www.pedestrian.tv/content/themes/pedestriantv/images/lifehacker.svg" alt="Lifehacker" loading="lazy">
</a>
<a href="https://www.gizmodo.com.au/" target="_blank">
<img src="https://www.pedestrian.tv/content/themes/pedestriantv/images/gizmodo.svg" alt="Gizmodo" loading="lazy">
</a>
<a href="https://www.kotaku.com.au/" target="_blank">
<img src="https://www.pedestrian.tv/content/themes/pedestriantv/images/kotaku.svg" alt="Kotaku" loading="lazy">
</a>
</div>
<div class="copy_menu">&copy; 2021 Pedestrian Group Pty Ltd</div>
<ul id="menu-footer" class="top-menu-right"><li id="menu-item-241169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-241169"><a title="Privacy Policy" href="https://www.pedestrian.tv/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-213229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-213229"><a title="Terms of Service" href="https://www.pedestrian.tv/website-terms-of-service/">Terms of Service</a></li>
<li id="menu-item-241178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241178"><a title="Delivery &amp; Refund Policy" href="https://www.pedestrian.tv/website-delivery-refund/">Delivery & Refund Policy</a></li>
<li id="menu-item-241179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241179"><a title="Contact" href="https://www.pedestrian.tv/contact-pedestrian-tv/">Contact</a></li>
<li id="menu-item-241180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241180"><a title="About" href="https://www.pedestrian.tv/about-pedestrian-tv/">About</a></li>
</ul> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="ped-network menu_collapse menu_bg_black">
<div class="bk_close_div black_bg">
<div class="container">
<div class="ped-close div_close white">
<button type="button" class="navbar-close navbar-left" data-toggle="collapse" data-target="#navbar-collapse-main">
<img src="https://www.pedestrian.tv/content/themes/pedestriantv/images/Close-white.svg" width="24px" height="24px" loading="lazy">
</button>
<a href="#" class="ped-lnk-network">Network</a>
</div>
</div>
</div>
<div class="menu_nav_scroll">
<div class="menu_blk_black">
<div class="container">
<div class="container-fluid">
<div class="row">
<div class="col-md-12">
<div class="menu-ped">
<a href="https://www.pedestrian.tv/" rel="home" class="pedestrian-logo">
<svg xmlns="http://www.w3.org/2000/svg" width="100%" viewBox="0 0 340 54.938">
<path id="pedestrian_logo" class="logo-1" d="M240.746,34.445h25.9V45.2H252.155v7.474h14.054V63.428H252.155v8.239H266.65V82.44h-25.9V34.445Zm68.49,0h25.926V45.2h-14.5v7.474h14.054V63.428H320.657v8.239h14.5V82.44H309.236V34.445Zm60.058,34.177c0,7-3.915,14.722-16.266,14.722-13.49,0-16.839-9.083-16.839-15.237V66.548h11.846c0,5.578,3.357,6.542,4.863,6.542a4.561,4.561,0,0,0,4.539-4.6c0-3.186-1.945-3.966-9.147-7.069-3.265-1.356-11.4-4.733-11.4-13.748s8.5-14.135,16.324-14.135c4.607,0,9.586,1.745,12.617,5.446,2.76,3.491,2.955,6.741,3.089,9.467h-11.8c-0.248-1.624-.635-4.668-4.285-4.668a3.929,3.929,0,0,0-4.1,3.759c0,2.85,1.25,3.43,9.643,7.327C367.094,58.892,369.294,63.043,369.294,68.622ZM234.62,37.947c-2.515-2.15-5.736-3.5-14.368-3.5H205v48h11.405V67.392h5.184c7.246,0,10.388-1.36,13.6-4.157,2.961-2.6,4.918-7.711,4.918-12.581A16.5,16.5,0,0,0,234.62,37.947Zm-13.36,18.68h-4.855V45.2h4.411c2.594,0,7.877,0,7.877,5.657C228.693,56.626,223.538,56.626,221.26,56.626Zm62.129-22.181H267.937v48h16.331c17.708,0,24.02-11.031,24.02-24.129,0-5.257-1.072-10.379-4.281-14.913C297.951,34.445,288.632,34.445,283.389,34.445Zm1.573,37.222h-5.1V45.2h5.16c5.3,0,7.693,2.29,9.081,4.421a17.328,17.328,0,0,1,2.265,8.88C296.369,65.308,293.85,71.667,284.962,71.667Zm137.857-5.574c8.817-1.488,11.59-9.6,11.59-15.118,0-4.932-1.878-9.984-5.724-13.1-3.032-2.391-6.187-3.428-14.375-3.428H369.294V45.2H378.5V82.44H390.42V45.2h9.134V82.44h11.415v-15.5H411.1l10.782,15.5H435.5Zm-7.636-7.526h-4.214V45.2h4.344c4.591,0,7.681,2.147,7.681,6.5C422.994,54.04,422.178,58.567,415.183,58.567Zm21.061-24.122h11.931v48H436.244V34.445Zm108.756,0v48H534.663L516.88,53.249l-0.124.065,0.327,29.126h-8.138c0.185-.117.4-0.242,0.591-0.367,3.751-2.4,3.412-4.61,3.3-5a2.916,2.916,0,0,0-1.547-2.048,4.023,4.023,0,0,0-1.91-.437,9.48,9.48,0,0,0-3.12.639c-0.2.039-.388,0.063-0.6,0.1V34.445h10.281l18.024,30.16,0.124-.136-0.5-30.024H545ZM500.786,72.921L482.62,34.336h2.169l17.917,37.717Zm-7.51,3.4L473.514,34.336h1.813l19.427,41.311Zm2.488-1.137-19.219-40.85h1.816L497.27,74.513Zm-5,2.273L470.469,34.336h1.807l19.993,42.448Zm7.522-3.389L479.567,34.336h1.827l18.381,39.051Zm-44.1-1.579,15.359-32.637,0.607,1.293-14.961,31.82,1.477,0.7,14.389-30.6,0.619,1.3L457.668,74.147l1.49,0.706,13.414-28.562,0.634,1.3L460.154,75.318l1.486,0.7,12.469-26.508,0.607,1.307L462.631,76.492l1.924,0.9,11.334-24.113,12.02,25.461,1.837-.834L469.252,34.336h-2.306L449.924,70.477l1.766,0.834,16.332-34.682,0.608,1.307L452.693,71.785l1.494,0.706m56.545,3.465a1.136,1.136,0,0,1,.373.265,2,2,0,0,1,.66,1.123c0.044,0.087.416,1.79-2.848,3.867a11.85,11.85,0,0,1-7.636,1.855c-0.627-.019-2.375.114-2.943,0.791a0.75,0.75,0,0,0-.179.6,0.2,0.2,0,0,1,.057.081,5.74,5.74,0,0,1,.475,1.259l-5.955,2.577-0.114-.036c-0.028-.014-0.97-2.176-0.97-2.176,0-.024-3.609-2.19-2.4-5.968a9.183,9.183,0,0,1,.335-0.9l0.091-.207,0.213,0.027a11.356,11.356,0,0,0,9.16-3.928l0.185-.21,0.219,0.138a9.7,9.7,0,0,0,7.056,1.108c0.112-.032,2.713-1.077,4.224-0.265M466.9,86.409a1.96,1.96,0,0,1-.406,1.234c-0.053.071-1.049,1.488-4.794,0.414a11.93,11.93,0,0,1-6.434-4.476c-0.414-.483-1.671-1.715-2.546-1.7a0.756,0.756,0,0,0-.552.278,0.129,0.129,0,0,0-.022.1,8.434,8.434,0,0,1-.644,1.194l-2.07-.983V72.657a0.046,0.046,0,0,0,.025-0.01,6.4,6.4,0,0,1,.895-0.333l0.209-.075,0.13,0.167a11.33,11.33,0,0,0,9,4.284l0.288-.014,0.04,0.264a9.876,9.876,0,0,0,3.828,6.022c0.1,0.049,2.594,1.314,3.006,2.984A2.952,2.952,0,0,1,466.9,86.409Z" transform="translate(-205 -33.531)" />
</svg>
</a>
<a href="https://www.pedestrian.tv/jobs/" rel="home" data-element-tracking="jobs-logo" class="ptv-job-logo">
<i class="pd-icon pd-icon-jobs-logo"></i>
</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="page page-home">
<div id="ad-slot_out-of-page_section-index-1_pos-1" class="ad-slot ad-slot-rendering ad-slot-out-of-page" data-section-index=1></div>
<script type="text/javascript">
		if (typeof siteads.queue !== 'undefined') {
			siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"out-of-page","targeting":{"ptv-pos":1},"provider":"google-dfp","element_id":"ad-slot_out-of-page_section-index-1_pos-1"} );
		}
	</script>
<div class="container">
<div class="content">
<div id="articles-wrapper" class="home-content-margin col-md-12">
<article id="post-1699774" class="article-group" data-section-index="1" data-href="https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/" data-title="Snoop Dogg Just Announced His First Aussie Tour Since 2014 &amp; The Grass Really Do Be Greener" data-post-id="1699774" data-view-count-enabled="true">
<div id="ad-slot_left-tower_section-index-1" class="ad-slot ad-slot-rendering left-tower-ad" data-sticky-bottom-offset=34 data-sticky-container-selector=.article-group[data-post-id=&quot;1699774&quot;] data-section-index=1></div>
<script type="text/javascript">
		if (typeof siteads.queue !== 'undefined') {
			siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"left-tower","provider":"google-dfp","element_id":"ad-slot_left-tower_section-index-1","js_callback":"stickyAds"} );
		}
	</script>
<div id="ad-slot_right-tower_section-index-1" class="ad-slot ad-slot-rendering right-tower-ad" data-sticky-bottom-offset=34 data-sticky-container-selector=.article-group[data-post-id=&quot;1699774&quot;] data-section-index=1></div>
<script type="text/javascript">
		if (typeof siteads.queue !== 'undefined') {
			siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"right-tower","provider":"google-dfp","element_id":"ad-slot_right-tower_section-index-1","js_callback":"stickyAds"} );
		}
	</script>
<div id="ad-slot_top-leader_section-index-1" class="ad-slot ad-slot-rendering top-leader-ad" data-section-index=1></div>
<script type="text/javascript">
		if (typeof siteads.queue !== 'undefined') {
			siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"top-leader","provider":"google-dfp","element_id":"ad-slot_top-leader_section-index-1"} );
		}
	</script>
<div class="show-on-mobile top-mobile-ad">
<div id="ad-slot_mobile-leader_section-index-1" class="ad-slot ad-slot-rendering mrec-cont padd_mrec" data-section-index=1></div>
<script type="text/javascript">
		if (typeof siteads.queue !== 'undefined') {
			siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"mobile-leader","provider":"google-dfp","element_id":"ad-slot_mobile-leader_section-index-1"} );
		}
	</script>
</div>
<h1 class="article-title" data-href="https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/">Snoop Dogg Just Announced His First Aussie Tour Since 2014 &amp; The Grass Really Do Be Greener</h1>
<div class="sections">
<section id="main-content-1" class="main">
<div class="article">
<section class="article-header">
<div class="entry-thumbnail">
<div class="entry-thumbnail__picture single-main">
<span class="entry-thumbnail__placeholder-ctn"></span>
<div class="entry-thumbnail__picture-ctn">
<picture>
<source media="(min-width: 0px)" sizes="1280px" srcset="https://imgix.pedestrian.tv/content/uploads/2021/09/07/snoop-dogg-tour-site.jpg?ar=16%3A9&auto=format&crop=focal&fit=crop&q=65&w=1200 1200w">
<img src="https://imgix.pedestrian.tv/content/uploads/2021/09/07/snoop-dogg-tour-site.jpg?ar=16%3A9&auto=format&crop=focal&fit=crop&q=65&w=1200" loading="lazy" width="720" height="405" class="attachment-picture attachment-id-1699801 config-handle_single-main cached-image-data" alt="Snoop Dogg Just Announced His First Aussie Tour Since 2014 &amp; The Grass Really Do Be Greener" data-imgix-image="true">
</picture>
</div>
</div>
</div>
<footer>
<div class="article-meta">
<div class="article-author">By <a class="author-link" href="https://www.pedestrian.tv/author/courtneypedestriangroup-com-au/">Courtney Fry</a></div>
<div class="article-date"><span class="published-on">Published</span> September 7, 2021</div>
</div>
<a class="facebook-share" href="https://www.facebook.com/sharer/sharer.php?u=https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/" onclick="return !window.open(this.href, 'Facebook', 'width=640,height=580')" rel="noopener">
<img src="https://www.pedestrian.tv/content/themes/pedestriantv/images/facebook-w-1.png" width="90px" height="30px" alt="Share on Facebook">
</a>
</footer>
</section>
<div class="article-body">
<p>It&#8217;s been a minute between gin and juices, but <strong>Snoop Dogg</strong> has just announced he&#8217;ll be coming back down under for a huge arena tour in 2022. At this point we&#8217;ve just gotta cross all our fingers and toes that this tour actually lands and we can emerge from our kennels and choof along to get down with the big Dogg himself.</p><div id="brightcove-video-container-88909441" class="brightcove-video-container" style="display: none">
<p class="brightcove-video-related"></p>
<div class="brightcove-video">
<div class="brightcove-video-inner">
<span class="bightcove-close-video-cross" data-src="https://www.pedestrian.tv/content/mu-plugins/pedestrian-video-front-end/template/assets/img/close-button.png" alt="Close video"></span>
<p class="bightcove-close-video-swipe" data-text="Swipe to close"></p>
<div class="vjs-playlist-player-container">
<video-js id="brightcove-video-88909441" data-account="6103636748001" data-player="zf2tqmk2" data-embed="default" controls="" data-playlist-id="1656564537623554858" data-application-id="" class="vjs-fluid" muted playsinline></video-js>
</div>
</div>
</div>
<p class="brightcove-video-title"></p>
</div>
<p>The <em>I Wanna Thank Me</em> tour is set to be Snoop&#8217;s first Australian shows since he headlined the final Big Day Out way back in 2014, and sees the rap legend, munchies lord, and friend of both Mary Jane and <strong>Martha Stewart</strong> celebrating his 17th (!!!) album of the same name.</p>
<p>Hell, he&#8217;s even released <em>another</em> album since then, because the big dogg&#8217;s gotta eat, so expect to hear him roll through tracks off <em>From tha Streets 2 tha Suites</em> as well.</p>
<div class="show-on-mobile ad-slot-cntr" style="margin: 10px 0px;">
<div id="ad-slot_mobile-mrec_section-index-1_pos-1" class="ad-slot ad-slot-rendering mrec-cont padd_mrec" data-slot=/1027487/ptvmobileamp width=300 height=250 data-multi-size=320x250 data-section-index=1></div>
<p> <script type="text/javascript">
			if (typeof siteads.queue !== 'undefined') {
				siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"mobile-mrec","targeting":{"ptv-pos":"1"},"provider":"google-dfp","element_id":"ad-slot_mobile-mrec_section-index-1_pos-1"} );
			}
		</script>
</div>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CTf-Cw7rnT8/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:640px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/CTf-Cw7rnT8/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div>
</div>
<p></a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a href="https://www.instagram.com/p/CTf-Cw7rnT8/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">A post shared by TEG Live (@teg_live)</a></p>
</div>
</blockquote>
<p><script async src="//platform.instagram.com/en_US/embeds.js"></script></p>
<p>Snoop&#8217;s also coming out here to promote his 2019 documentary (also called <em>I Wanna Thank Me</em>), which delves into the 25-year-long career of the West Coast icon, from his &#8217;92 feature on <strong>Dr. Dre</strong>&#8216;s <em>The Chronic</em> to releasing cookbooks and his own strains of devil&#8217;s lettuce, and winning over mums and the world in the process. He&#8217;s a working dogg, what can I say?</p>
<p>Snoop Dogg&#8217;s Australian tour will kick off at Perth&#8217;s RAC Arena on October 26, 2022, before whipping around the country over the rest of the month, before winding things up in Brisbane at the top of November.</p>
<p>Tickets are on sale through <a href="https://premier.ticketek.com.au/shows/show.aspx?sh=SNOOPDOG22" target="_blank" rel="nofollow noopener">Ticketek</a> from Monday September 13 at 4pm local time (missed opportunity to set &#8217;em live at 4.20 here), and there&#8217;s a cheeky presale happening from Friday September 10 through the <a href="https://plus.telstra.com.au/tickets" target="_blank" rel="nofollow noopener">TelstraPlus website</a>.</p>
<div id="ad-slot_out-of-page-mobile_section-index-1_pos-2" class="ad-slot ad-slot-rendering padd_mrec ad-slot-out-of-page ad-slot-out-of-page-mobile" data-section-index=1></div>
<p> <script type="text/javascript">
		if (typeof siteads.queue !== 'undefined') {
			siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"out-of-page-mobile","targeting":{"ptv-pos":2},"provider":"google-dfp","element_id":"ad-slot_out-of-page-mobile_section-index-1_pos-2"} );
		}
	</script></p>
<div class="related-content read-more-content">
<span>READ MORE</span>
<a href="https://www.pedestrian.tv/music/snoop-dogg-sustainability-interview/"><div>We Chatted To Ya Boi Snoop Dogg About Martha Stewart & Going Green (In More Ways Than One)</div></a>
</div>
<p>We&#8217;ve got a whole year to prepare for this: perfecting our Chandon pour, finding the perfect knock-off Rolex, re-watching his 2007 reality show <em>Snoop Dogg&#8217;s Father Hood</em>, and getting the gin and juice mix just right.</p>
<div class="show-on-mobile ad-slot-cntr" style="margin: 10px 0px;">
<div id="ad-slot_mobile-mrec_section-index-1_pos-2" class="ad-slot ad-slot-rendering mrec-cont padd_mrec" data-slot=/1027487/ptvmobileamp width=300 height=250 data-multi-size=320x250 data-section-index=1></div>
<p> <script type="text/javascript">
			if (typeof siteads.queue !== 'undefined') {
				siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"mobile-mrec","targeting":{"ptv-pos":"2"},"provider":"google-dfp","element_id":"ad-slot_mobile-mrec_section-index-1_pos-2"} );
			}
		</script>
</div>
<p>See you in the Dogg house, fingers fuckin&#8217; crossed.
</p>
<h3 style="text-align: center;">Snoop Dogg I Wanna Thank Me Australian Tour 2022</h3>
<p style="text-align: center;"><em>Wednesday 26 October</em><br />
<em>RAC Arena, Perth WA</em></p>
<p style="text-align: center;"><em>Friday 28 October</em><br />
<em>Qudos Bank Arena, Sydney NSW</em></p>
<p style="text-align: center;"><em>Saturday 29 October </em><br />
<em>Rod Laver Arena, Melbourne VIC</em></p>
<p style="text-align: center;"><em>Tuesday 1 November</em><br />
<em>Brisbane Entertainment Centre, Brisbane QLD</em></p>
<div class="posts-list">
<h2 class="posts-list__heading">More Stuff From PEDESTRIAN.TV</h2>
<div class="posts-list__cntr">
<ul>
<li class="">
<h5 class="title">
<a href="https://www.pedestrian.tv/music/the-wombats-australian-tour-2022/">
The Wombats Just Dropped Dates For A Huge 2022 Aussie Tour &amp; This Feels Like Nature Is Healing </a>
</h5>
</li>
<li class="">
<h5 class="title">
<a href="https://www.pedestrian.tv/entertainment/the-veronicas-drag-race-down-under/">
The Veronicas Just Announced They’re Gonna Be On Drag Race Down Under So Hook Us The Fuck Up </a>
</h5>
</li>
<li class="">
<h5 class="title">
<a href="https://www.pedestrian.tv/entertainment/sam-smith-non-binary-tattoo/">
Sam Smith Has A Sick New Tat Representing Their Non-Binary Identity And Now I Wanna Get Inked </a>
</h5>
</li>
<li class="">
<h5 class="title">
<a href="https://www.pedestrian.tv/online/taylor-swift-evermor-meme-roundup/">
13 Of The Best Memes About Taylor Swift Dropping Evermore And Rescuing The Trash Year 2020 </a>
</h5>
</li>
</ul>
</div>
</div>
<i>Image:
Getty Images / Gary Miller </i><br />
<a class="facebook-share-footer" href="https://www.facebook.com/sharer/sharer.php?u=https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/" onclick="return !window.open(this.href, 'Facebook', 'width=640,height=580')" rel="noopener">
<img src="https://www.pedestrian.tv/content/themes/pedestriantv/images/facebook-w-1.png" width="90px" height="30px" alt="Share on Facebook">
</a>
</div>
</div>
</section>
<div id="sticky-sidebar-1">
<div class="sidebar-content">
<aside id="mainaside">
<div class="sidebar-widget hide-on-mobile">
<div class="banner-widget clearfix">
<a id="banner-widget-1" href="https://www.pedestrian.tv/sponsored-jobs?utm_source=featurejobsbutton&amp;utm_medium=button&amp;utm_campaign=featurejobs">
<img width="300" height="100" src="https://imgix.pedestrian.tv/content/uploads/2021/04/14/Jobs-Additions_FeatureJobs.jpg?auto=format&fit=fill&q=65" loading="lazy" srcset="https://imgix.pedestrian.tv/content/uploads/2021/04/14/Jobs-Additions_FeatureJobs.jpg?auto=format&amp;fit=fill&amp;q=65 320w" sizes="100vw" class="attachment-image config-handle_widget-banner cached-image-data" data-imgix-image="true" /> </a>
</div>
</div><div class="sidebar-widget">
<div id="ad-slot_sidebar-mrec_section-index-1_pos-1" class="ad-slot ad-slot-rendering mrec-cont padd_mrec" data-section-index=1></div>
<script type="text/javascript">
		if (typeof siteads.queue !== 'undefined') {
			siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"sidebar-mrec","targeting":{"ptv-pos":"1"},"provider":"google-dfp","element_id":"ad-slot_sidebar-mrec_section-index-1_pos-1"} );
		}
	</script>
</div>
<div class="sidebar-widget">
<div class="panel-signup panel-dreamjob">
<i class="pd-icon pd-icon-jobs-logo"></i>
<span>FIND YOUR DREAM JOB HERE</span>
<a class="find-your-dream-job" href="https://www.pedestrian.tv/jobs/"></a>
</div>
</div><div class="sidebar-widget popular-jobs-widget">
<h2 class="breaking-news-title ">Recent Jobs</h2>
<div class="popular-jobs">
<div class="row">
<div class="col-md-12 col-sm-12">
<div class="job-summary">
<div class="info">
<span class="new">New</span>
</div>
<a class="body" href="https://www.pedestrian.tv/job/social-media-manager-138/" title="Social Media Manager">
<h3>Social Media Manager</h3>
<span class="position"> <em>Full-time - Melbourne</em></span>
</a>
</div>
</div>
</div>
<div class="row">
<div class="col-md-12 col-sm-12">
<div class="job-summary">
<div class="info">
<span class="new">New</span>
</div>
<a class="body" href="https://www.pedestrian.tv/job/despatch-co-ordinator/" title="Despatch Co-Ordinator">
<h3>Despatch Co-Ordinator</h3>
<span class="position"> <em>Part-time - Sydney</em></span>
</a>
</div>
</div>
</div>
<div class="row">
<div class="col-md-12 col-sm-12">
<div class="job-summary">
<div class="info">
<span class="new">New</span>
</div>
<a class="body" href="https://www.pedestrian.tv/job/marketing-intern-81/" title="Marketing Intern">
<h3>Marketing Intern</h3>
<span class="position"> <em>Internship / Work Experience - Sydney - $1 to $29,999</em></span>
</a>
</div>
</div>
</div>
<div class="row">
<div class="col-md-12 col-sm-12">
<div class="job-summary">
<div class="info">
<span class="new">New</span>
</div>
<a class="body" href="https://www.pedestrian.tv/job/marketing-and-social-media-intern-7/" title="Marketing and Social Media Intern">
<h3>Marketing and Social Media Intern</h3>
<span class="position"> <em>Internship / Work Experience - Melbourne - Unpaid</em></span>
</a>
</div>
</div>
</div>
</div>
</div><div class="sidebar-widget">
<div id="ad-slot_sidebar-mrec_section-index-1_pos-2" class="ad-slot ad-slot-rendering mrec-cont padd_mrec" data-section-index=1></div>
<script type="text/javascript">
		if (typeof siteads.queue !== 'undefined') {
			siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"sidebar-mrec","targeting":{"ptv-pos":"2"},"provider":"google-dfp","element_id":"ad-slot_sidebar-mrec_section-index-1_pos-2"} );
		}
	</script>
</div>
<div class="sidebar-widget sidebar-widget-outbrain">
<h2 class="breaking-news-title">From The Web</h2>
<div class="OUTBRAIN" data-src="https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/" data-widget-id="SB_1" data-section-index="1">
</div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
<script type="text/javascript">
	if ( 'undefined' !== typeof window.OBR &&
		'undefined' !== typeof window.OBR.extern ) {
		window.OBR.extern.researchWidget();
	}
</script>
</div>
<div class="sidebar-widget">
<div id="ad-slot_sidebar-mrec_section-index-1_pos-3" class="ad-slot ad-slot-rendering mrec-cont padd_mrec" data-section-index=1></div>
<script type="text/javascript">
		if (typeof siteads.queue !== 'undefined') {
			siteads.queue.push( {"site":"pedestriantv","pagetype":"article","ad_type":"article","sec":"music","amp":false,"article":"snoop dogg australian tour 2022","article-tags":["Rap","Snoop Dogg","Australian Tour","2022","Arena Tour","Tour Announcement","I Wanna Thank Me","Doggfather"],"native":["null"],"paid":"true","has_jw_player":"false","ad_location":"sidebar-mrec","targeting":{"ptv-pos":"3"},"provider":"google-dfp","element_id":"ad-slot_sidebar-mrec_section-index-1_pos-3"} );
		}
	</script>
</div>
</aside>
</div> </div>
<script type="text/javascript">
            ( function($) {
                var $sidebar = $( '#sticky-sidebar-1 > div' ),
                    $wrapper = $sidebar.parent().parent().find( 'section.main' );
                if( typeof stickySidebar == 'function' ) {
                    stickySidebar( $sidebar, $wrapper );
                } else {
                    $( document ).on( 'sticky_sidebar_loaded', function() {
                        stickySidebar( $sidebar, $wrapper );
                    } );
                }
            } )(jQuery);
        </script>
</div>
<section class="trending-articles" data-tracking-sent="false" data-articles-loaded="false">
<h3>Trending Now</h3>
<div class="trending-loading"><img src="https://www.pedestrian.tv/content/themes/pedestriantv/images/loader-grey.gif" /></div>
<div data-article-id="" data-article-slug="" class="trending-template rss-card trending-card">
<a href="#">
<div class="background-img"></div>
</a>
<p class="title dotdotdot">
<a href="#"></a>
</p>
<div class="sponsor"></div>
</div>
</section></article>
<div class="spinner"></div>
</div>
<div class="loading_buttons">
<a id="load-more-articles" href="#" style="display: none;">Load more articles</a>
<p id="all-articles-shown" style="display: none;">There are no more articles to be viewed</p>
<p id="loading-next-article" style="display: none;">Loading<span>.</span><span>.</span><span>.</span></p>
</div>
</div>
</div>
</div>
<div class="footer">
<div class="container">
<div class="sections">
<div class="section1">
<div class="panel-signup-footer">
<div class="panel-heading">Signup for pedestrian daily</div>
<div id="newsletter-signup-1803702012" class="panel-body">
<span class="success_message" style="display:none;"><div class="text-center">Thanks for signing up!</div></span>
<form data-id="embedded_signup:form" class="ctct-custom-form Form" name="embedded_signup" method="POST" action="https://visitor2.constantcontact.com/api/signup">
 
<input data-id="ca:input" type="hidden" name="ca" value="8e88cf51-7741-4bf5-9581-3cc0d157c7be">
<input data-id="list:input" type="hidden" name="list" value="2">
<input data-id="source:input" type="hidden" name="source" value="EFD">
<input data-id="required:input" type="hidden" name="required" value="list,email">
<input data-id="url:input" type="hidden" name="url" value="">
<input data-id="address_state:input" type="hidden" name="address_state" value="In menu">
<div class="form-group">
<div class="input-group input-group-sm">
<p data-id="Email Address:p"><input data-id="Email Address:input" type="email" name="email" value="" required="required" class="form-control" placeholder="Enter Your Email For Daily News"></p>
<span class="input-group-btn">
<button type="submit" class="Button ctct-button Button--block Button-secondary btn btn-primary" data-enabled="enabled">Submit</button>
</span>
</div>
</div>
</form>
</div>
<script type='text/javascript'>
  ( function($) {
      var $newsletter_form = $( '#newsletter-signup-1803702012' );
      if( typeof jQuery.fn.addNewsletter == 'function' ) {
          $newsletter_form.addNewsletter();
      } else {
          $( document ).on( 'add_newsletter_loaded', function() {
              $newsletter_form.addNewsletter();
          } );
      }
  } )(jQuery);
</script> </div>
<ul class="footer-social-icons">
<li>
<a href="https://www.facebook.com/pedestriandottv/" target="_blank">
<i class="pd-icon pd-icon-social-facebook"></i>
</a>
</li>
<li>
<a href="https://twitter.com/pedestriandaily" target="_blank">
<i class="pd-icon pd-icon-social-twitter"></i>
</a>
</li>
<li>
<a href="https://www.instagram.com/pedestriantv/" target="_blank">
<i class="pd-icon pd-icon-social-instagram"></i>
</a>
</li>
<li>
<a href="https://www.snapchat.com/add/pedestrian.tv" target="_blank">
<i class="pd-icon pd-icon-social-snapchat"></i>
</a>
</li>
<li>
<a href="https://www.youtube.com/user/pedestriantv" target="_blank">
<i class="pd-icon pd-icon-social-youtube"></i>
</a>
</li>
<li>
<a href="mailto:editor@pedestriangroup.com.au">
<i class="pd-icon pd-icon-social-email"></i>
</a>
</li>
</ul>
</div>
<div class="section2">
<div class="footer-logo">
<a href="https://www.pedestrian.tv/" rel="home" class="pedestrian-logo">
<svg xmlns="http://www.w3.org/2000/svg" width="340" height="54.938" viewBox="0 0 340 54.938">
<defs>
<style>
      .cls-1 {
        fill: #fff;
        fill-rule: evenodd;
      }
    </style>
</defs>
<path id="pedestrian_logo" class="cls-1" d="M240.746,34.445h25.9V45.2H252.155v7.474h14.054V63.428H252.155v8.239H266.65V82.44h-25.9V34.445Zm68.49,0h25.926V45.2h-14.5v7.474h14.054V63.428H320.657v8.239h14.5V82.44H309.236V34.445Zm60.058,34.177c0,7-3.915,14.722-16.266,14.722-13.49,0-16.839-9.083-16.839-15.237V66.548h11.846c0,5.578,3.357,6.542,4.863,6.542a4.561,4.561,0,0,0,4.539-4.6c0-3.186-1.945-3.966-9.147-7.069-3.265-1.356-11.4-4.733-11.4-13.748s8.5-14.135,16.324-14.135c4.607,0,9.586,1.745,12.617,5.446,2.76,3.491,2.955,6.741,3.089,9.467h-11.8c-0.248-1.624-.635-4.668-4.285-4.668a3.929,3.929,0,0,0-4.1,3.759c0,2.85,1.25,3.43,9.643,7.327C367.094,58.892,369.294,63.043,369.294,68.622ZM234.62,37.947c-2.515-2.15-5.736-3.5-14.368-3.5H205v48h11.405V67.392h5.184c7.246,0,10.388-1.36,13.6-4.157,2.961-2.6,4.918-7.711,4.918-12.581A16.5,16.5,0,0,0,234.62,37.947Zm-13.36,18.68h-4.855V45.2h4.411c2.594,0,7.877,0,7.877,5.657C228.693,56.626,223.538,56.626,221.26,56.626Zm62.129-22.181H267.937v48h16.331c17.708,0,24.02-11.031,24.02-24.129,0-5.257-1.072-10.379-4.281-14.913C297.951,34.445,288.632,34.445,283.389,34.445Zm1.573,37.222h-5.1V45.2h5.16c5.3,0,7.693,2.29,9.081,4.421a17.328,17.328,0,0,1,2.265,8.88C296.369,65.308,293.85,71.667,284.962,71.667Zm137.857-5.574c8.817-1.488,11.59-9.6,11.59-15.118,0-4.932-1.878-9.984-5.724-13.1-3.032-2.391-6.187-3.428-14.375-3.428H369.294V45.2H378.5V82.44H390.42V45.2h9.134V82.44h11.415v-15.5H411.1l10.782,15.5H435.5Zm-7.636-7.526h-4.214V45.2h4.344c4.591,0,7.681,2.147,7.681,6.5C422.994,54.04,422.178,58.567,415.183,58.567Zm21.061-24.122h11.931v48H436.244V34.445Zm108.756,0v48H534.663L516.88,53.249l-0.124.065,0.327,29.126h-8.138c0.185-.117.4-0.242,0.591-0.367,3.751-2.4,3.412-4.61,3.3-5a2.916,2.916,0,0,0-1.547-2.048,4.023,4.023,0,0,0-1.91-.437,9.48,9.48,0,0,0-3.12.639c-0.2.039-.388,0.063-0.6,0.1V34.445h10.281l18.024,30.16,0.124-.136-0.5-30.024H545ZM500.786,72.921L482.62,34.336h2.169l17.917,37.717Zm-7.51,3.4L473.514,34.336h1.813l19.427,41.311Zm2.488-1.137-19.219-40.85h1.816L497.27,74.513Zm-5,2.273L470.469,34.336h1.807l19.993,42.448Zm7.522-3.389L479.567,34.336h1.827l18.381,39.051Zm-44.1-1.579,15.359-32.637,0.607,1.293-14.961,31.82,1.477,0.7,14.389-30.6,0.619,1.3L457.668,74.147l1.49,0.706,13.414-28.562,0.634,1.3L460.154,75.318l1.486,0.7,12.469-26.508,0.607,1.307L462.631,76.492l1.924,0.9,11.334-24.113,12.02,25.461,1.837-.834L469.252,34.336h-2.306L449.924,70.477l1.766,0.834,16.332-34.682,0.608,1.307L452.693,71.785l1.494,0.706m56.545,3.465a1.136,1.136,0,0,1,.373.265,2,2,0,0,1,.66,1.123c0.044,0.087.416,1.79-2.848,3.867a11.85,11.85,0,0,1-7.636,1.855c-0.627-.019-2.375.114-2.943,0.791a0.75,0.75,0,0,0-.179.6,0.2,0.2,0,0,1,.057.081,5.74,5.74,0,0,1,.475,1.259l-5.955,2.577-0.114-.036c-0.028-.014-0.97-2.176-0.97-2.176,0-.024-3.609-2.19-2.4-5.968a9.183,9.183,0,0,1,.335-0.9l0.091-.207,0.213,0.027a11.356,11.356,0,0,0,9.16-3.928l0.185-.21,0.219,0.138a9.7,9.7,0,0,0,7.056,1.108c0.112-.032,2.713-1.077,4.224-0.265M466.9,86.409a1.96,1.96,0,0,1-.406,1.234c-0.053.071-1.049,1.488-4.794,0.414a11.93,11.93,0,0,1-6.434-4.476c-0.414-.483-1.671-1.715-2.546-1.7a0.756,0.756,0,0,0-.552.278,0.129,0.129,0,0,0-.022.1,8.434,8.434,0,0,1-.644,1.194l-2.07-.983V72.657a0.046,0.046,0,0,0,.025-0.01,6.4,6.4,0,0,1,.895-0.333l0.209-.075,0.13,0.167a11.33,11.33,0,0,0,9,4.284l0.288-.014,0.04,0.264a9.876,9.876,0,0,0,3.828,6.022c0.1,0.049,2.594,1.314,3.006,2.984A2.952,2.952,0,0,1,466.9,86.409Z" transform="translate(-205 -33.531)" />
</svg>
</a>
</div>
<div class="copyright">&copy; 2021 Pedestrian Group Pty Ltd</div>
<ul id="menu-footer-1" class="footer-links"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-241169"><a title="Privacy Policy" href="https://www.pedestrian.tv/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-213229"><a title="Terms of Service" href="https://www.pedestrian.tv/website-terms-of-service/">Terms of Service</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241178"><a title="Delivery &amp; Refund Policy" href="https://www.pedestrian.tv/website-delivery-refund/">Delivery & Refund Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241179"><a title="Contact" href="https://www.pedestrian.tv/contact-pedestrian-tv/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241180"><a title="About" href="https://www.pedestrian.tv/about-pedestrian-tv/">About</a></li>
</ul> </div>
</div>
</div>
</div>
<div id="signup-popup" class="modal-box-jobs">
<div class="modal-box-content">
<div class="modal-body">
<div class="row">
 <div class="col-md-12 col-sm-12 col-xs-12">
<div id="signup">
<div class="header-modal">
<h2>Sign Up</h2>
<p>Sign up with your Facebook<br>or Linkedin account</p>
</div>
<div id="popup-signup-buttons">

<style type="text/css">
.wp-social-login-connect-with{}.wp-social-login-provider-list{}.wp-social-login-provider-list a{}.wp-social-login-provider-list img{}.wsl_connect_with_provider{}</style>
<div class="wp-social-login-widget">
<div class="wp-social-login-connect-with">Connect with:</div>
<div class="wp-social-login-provider-list">
<a rel="nofollow" href="https://www.pedestrian.tv/wp/wp-login.php?action=wordpress_social_authenticate&#038;mode=login&#038;provider=Facebook&#038;redirect_to=https%3A%2F%2Fwww.pedestrian.tv%2Fmusic%2Fsnoop-dogg-australian-tour-2022%2F" title="Connect with Facebook" class="wp-social-login-provider wp-social-login-provider-facebook" data-provider="Facebook">
<img alt="Facebook" title="Connect with Facebook" src="https://www.pedestrian.tv/content/plugins/wordpress-social-login-modified/assets/img/32x32/wpzoom/facebook.png" />
</a>
<a rel="nofollow" href="https://www.pedestrian.tv/wp/wp-login.php?action=wordpress_social_authenticate&#038;mode=login&#038;provider=LinkedIn&#038;redirect_to=https%3A%2F%2Fwww.pedestrian.tv%2Fmusic%2Fsnoop-dogg-australian-tour-2022%2F" title="Connect with LinkedIn" class="wp-social-login-provider wp-social-login-provider-linkedin" data-provider="LinkedIn">
<img alt="LinkedIn" title="Connect with LinkedIn" src="https://www.pedestrian.tv/content/plugins/wordpress-social-login-modified/assets/img/32x32/wpzoom/linkedin.png" />
</a>
</div>
<div class="wp-social-login-widget-clearing"></div>
</div>


</div>
<div class="copy-modal mt-5">
<h2>Sign up with email</h2>
</div>
<div id="popup-email-signup-form" class="jobs-signup-form">
<form action="https://www.pedestrian.tv/register/process/" id="signup" method="post" class="row">
<div class="form_field col-md-6">
<label>First Name</label>
<input name="first_name" type="text" placeholder="First name" class="half">
</div>
<div class="form_field col-md-6">
<label>Last Name</label>
<input name="last_name" type="text" placeholder="Last name" class="half">
</div>
<div class="form_field col-md-12">
<label>Email address</label>
<input name="user_email" type="text" placeholder="Email">
</div>
<div class="form_field col-md-12">
<label>Create Password</label>
<input name="password" type="password" placeholder="Create Password">
</div>
<div class="form_field sign-up-type-wrapper col-md-12">
<div class="inline-checkboxes">
<input id="sign-up-type-seeker" type="checkbox" name="sign-up-type[]" value="seeker">
<label for="sign-up-type-seeker">I'm a job seeker*</label>
 </div>
<div class="inline-checkboxes">
<input id="sign-up-type-employer" type="checkbox" name="sign-up-type[]" value="employer">
<label for="sign-up-type-employer">I'm an employer*</label>
</div>
<p class="sign-up-type-warning">Please select at least one of the following options to continue</p>
<p class="condition-text">By signing up, you agree to Pedestrian Group's Terms of Service and consent to our Privacy Policy.</p>
</div>
<div class="form_field col-md-12 submit-button mt-3">
<input type="submit" value="Sign up" class="btn-jobs">
</div>
<input type="hidden" name="repeat_password_required" value="0">
<input type="hidden" name="auto_login" value="1">
<input type="hidden" name="redirect_to" value="https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/">
</form>
</div>
<div class="desc mt-5">
<p>Already registered? <a href="https://www.pedestrian.tv/login?redirect_to=https://www.pedestrian.tv/music/snoop-dogg-australian-tour-2022/">Login here</a></p>
</div>
</div>
</div>
</div>
<a class="close" href="#">&times;</a>
</div>
</div>
</div>
<div id="login-popup" class="modal-box-jobs">
<div class="modal-box-content">
<div class="modal-body">
<div class="row">
<div class="col-md-12 col-sm-12 col-xs-12">
<div class="login-form">
<div class="header-modal">
<h2>Login</h2>
<p>Login with your Facebook<br>or Linkedin account</p>
</div>

<style type="text/css">
.wp-social-login-connect-with{}.wp-social-login-provider-list{}.wp-social-login-provider-list a{}.wp-social-login-provider-list img{}.wsl_connect_with_provider{}</style>
<div class="wp-social-login-widget">
<div class="wp-social-login-connect-with">Connect with:</div>
<div class="wp-social-login-provider-list">
<a rel="nofollow" href="https://www.pedestrian.tv/wp/wp-login.php?action=wordpress_social_authenticate&#038;mode=login&#038;provider=Facebook&#038;redirect_to=https%3A%2F%2Fwww.pedestrian.tv%2Fmusic%2Fsnoop-dogg-australian-tour-2022%2F" title="Connect with Facebook" class="wp-social-login-provider wp-social-login-provider-facebook" data-provider="Facebook">
<img alt="Facebook" title="Connect with Facebook" src="https://www.pedestrian.tv/content/plugins/wordpress-social-login-modified/assets/img/32x32/wpzoom/facebook.png" />
</a>
<a rel="nofollow" href="https://www.pedestrian.tv/wp/wp-login.php?action=wordpress_social_authenticate&#038;mode=login&#038;provider=LinkedIn&#038;redirect_to=https%3A%2F%2Fwww.pedestrian.tv%2Fmusic%2Fsnoop-dogg-australian-tour-2022%2F" title="Connect with LinkedIn" class="wp-social-login-provider wp-social-login-provider-linkedin" data-provider="LinkedIn">
<img alt="LinkedIn" title="Connect with LinkedIn" src="https://www.pedestrian.tv/content/plugins/wordpress-social-login-modified/assets/img/32x32/wpzoom/linkedin.png" />
</a>
</div>
<div class="wp-social-login-widget-clearing"></div>
</div>

<div class="copy-modal mt-5">
<h2>Login with email</h2>
</div>
<form name="loginform" id="loginform" action="/wp/wp-login.php" method="post" class="row">
<input type="hidden" name="repeat_password_required" value="0">
<input type="hidden" name="auto_login" value="1">
<input type="hidden" name="redirect_to" value="">
<div class="form_field col-12">
<label>Email address</label>
<input type="text" name="log" id="user_login" placeholder="Email address" class="input" value="" size="20">
</div>
<div class="form_field col-12">
<label>Password</label>
<input type="password" name="pwd" id="user_pass" placeholder="Password" class="input" value="" size="20">
</div>
<div class="login-submit col-12 mt-3">
<input type="submit" name="wp-submit" id="wp-submit" class="button-primary btn-jobs" value="Login">
</div>
<div class="form_field col-12 mt-3">
<div class="row align-items-center">
<div class="login-submit col-6">
<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" class="ez-hide"> Wanna be remembered?</label></p>
</div>
<div class="login-submit col-6 text-right">
<a class="login-pwd" href="https://www.pedestrian.tv/lost-password/">Forgot yo&#039; Password?</a>
</div>
</div>
</div>
<div class="login-register col-12 mt-5 text-right">
<a href="https://www.pedestrian.tv/register/"><span>Haven&#039;t registered?</span> <span class="bold">Sign up</span></a>
</div>
</form>
</div>
</div>
</div>
<a class="close" href="#">&times;</a>
</div>
</div>
</div>
<script>
window.PARSELY = window.PARSELY || {
	urlref: window.location,
	onload: function() {
		console.log( "PARSE.LY: inf scroll tracking loaded" );

		window.PARSELY.urlref = location.href;

		jQuery( document ).on( "inf-scroll:new-page", function() {

			var tracking_params = {
				url:    location.href,
				urlref: window.PARSELY.urlref,
				js:     1
			};

			// Set the urlref for the next inf scroll article.
			window.PARSELY.urlref = location.href;

			// Send the Parsely tracking beacon and we are done.
			PARSELY.beacon.trackPageView( tracking_params );
			console.log( "PARSE.LY: inf scroll tracking triggered" );

			return true;

		} );
	}
};
</script>
<script>
		if ( window.innerWidth > document.body.clientWidth ) {
			document.body.classList.add( 'has-vertical-scrollbar' );
		}
	</script>

<div id="nineau_tracking">
<script type="text/javascript">
                NINEAU_ThirdParty.renderTracking();
            </script>

</div>

<link rel='stylesheet' id='brightcove-videos-front-end-css' href='https://www.pedestrian.tv/content/themes/pedestriantv/css/brightcove-videos.1580358496.css' type='text/css' media='all' />
<script type='text/javascript' src='https://www.pedestrian.tv/wp/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/wp/wp-includes/js/jquery/ui/mouse.min.js?ver=1.12.1' id='jquery-ui-mouse-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/wp/wp-includes/js/jquery/ui/draggable.min.js?ver=1.12.1' id='jquery-ui-draggable-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/brightcove-videos.1602453930.js' id='brightcove-videos-front-end-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/menu.1566951739.js' id='pedestrian-menu-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/jquery.easing.min.1566951736.js' id='easing-js-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/slick.min.1566951742.js' id='slick-js-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/jquery.easy-ticker.min.1566951741.js' id='ticker-js-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/bootstrap/js/bootstrap.min.js?ver=5.8' id='bootstrap-js-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/navigation.1566951759.js' id='pedestrian-navigation-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/skip-link-focus-fix.1566951759.js' id='pedestrian-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/trigger-point.1566951742.js' id='trigger-point-js'></script>
<script type='text/javascript' id='pedestrian-scroll-js-extra'>
/* <![CDATA[ */
var scrollVars = {"ajaxurl":"https:\/\/www.pedestrian.tv\/wp\/wp-admin\/admin-ajax.php","article_id":"1699774","rest_base_url":"https:\/\/www.pedestrian.tv\/wp-json\/pedestrian\/v1\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/scroll.1612929255.js' id='pedestrian-scroll-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/newsletter.1566951737.js' id='newsletter-script-js'></script>
<script type='text/javascript' id='pedestrian-custom-js-extra'>
/* <![CDATA[ */
var variables = {"template_directory_uri":"https:\/\/www.pedestrian.tv\/content\/themes\/pedestriantv"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/custom.1566951737.js' id='pedestrian-custom-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/forms.1566951740.js' id='pedestrian-forms-js'></script>
<script type='text/javascript' id='pedestrian-scripts-js-extra'>
/* <![CDATA[ */
var variables = {"recaptcha_key":"6LdQqzQUAAAAAIOuFSgYpgtXzmOs4sF3R4OiiEHx","jobs_search":{"base":"jobs\/search\/","classification":"jobs-in","location":"jobs"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/scripts.1611708967.js' id='pedestrian-scripts-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/sticky-sidebar.1566951759.js' id='pedestrian-sticky-sidebar-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/ads-features.1590373671.js' id='pedestrian-sticky-ads-js'></script>
<script type='text/javascript' id='domain-com-au-search-js-extra'>
/* <![CDATA[ */
var domain_search_tracking_url = "https:\/\/www.pedestrian.tv\/domain-search-tracking\/";
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/domain-com-au-search.1566951756.js' id='domain-com-au-search-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/sticky-desktop-leaderboard.1590193318.js' id='sticky-desktop-leaderboard-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/wp/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2' id='jquery-touch-punch-js'></script>
<script type='text/javascript' id='brightcove-video-manager-js-extra'>
/* <![CDATA[ */
var brightcoveVideoManagerConfig = {"countries":["AU","NZ"]};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.pedestrian.tv/content/mu-plugins/pedestrian-video-front-end/template/assets/js/brightcove-video-manager.1621384825.js" id="brightcove-video-manager-js" async="async"></script>
<script type='text/javascript' async="async" src='https://s.skimresources.com/js/88665X1596501.skimlinks.js?ver=5.8' id='skimlinks-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/js/student-flights-widget.1566951739.js' id='student-flights-widget-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/quiz/js/quiz-main.1566951813.js' id='pedestrian-quiz-main-js-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/quiz/js/quiz-main-button.1566951813.js' id='pedestrian-quiz-main-button-js-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/quiz/js/quiz-checkbox-and-radio.1600999536.js' id='pedestrian-quiz-checkbox-and-radio-js-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/quiz/js/quiz-image-select.1566951812.js' id='pedestrian-quiz-image-select-js-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/themes/pedestriantv/quiz/js/quiz-entry-submit.1612744619.js' id='pedestrian-quiz-entry-submit-js-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/content/plugins/page-links-to/dist/new-tab.js?ver=3.3.5' id='page-links-to-js'></script>
<script type='text/javascript' src='https://www.pedestrian.tv/wp/wp-includes/js/wp-embed.min.js?ver=5.8' id='wp-embed-js'></script>
<script type="text/javascript">
				window._taboola = window._taboola || [];
				_taboola.push( { article: 'auto' } );
				! function( e, f, u, i ) {
					if ( ! document.getElementById( i ) ) {
						e.async = 1;
						e.src = u;
						e.id = i;
						f.parentNode.insertBefore( e, f );
						console.log( '%cTaboola Assets Loaded', 'background: #242424; color: orchid;' );
					}
				}( document.createElement( 'script' ), document.getElementsByTagName( 'script' )[ 0 ],
					'//cdn.taboola.com/libtrc/alluremedia-pedestrian/loader.js', 'tb_loader_script' );
				if ( window.performance && typeof window.performance.mark == 'function' ) {
					window.performance.mark( 'tbl_ic' );
				}
			</script>
</body>
</html>